Résolu Problème de compatibilité selon les navigateurs

Darky75

Membre Premium
Premium
Inscription
27 Septembre 2013
Messages
788
J'aimes
98
Points
3 845
#1
Bonjour,
J'ai récemment ressenti l'envie de me créé un site Web perso,
Ayant quelque base en codage je pensais que sa irait,
Mais en fait non :nerveux2:

Je vous expose donc mon problème,
Selon le navigateur, ma page Web ne s'affiche pas de la même façon,
A commencé par le fond,
Sur PC: (Tout S'affiche normalement)

proxy.php?image=http%3A%2F%2Fimage.noelshack.com%2Ffichiers%2F2013%2F49%2F1386167274-capture-pc.png&hash=f5234fab55a7b243d33bb1a04d96d86d


Sur mon Ipad: (Des barres blanches apparaissent en haut et en bas:d:)

proxy.php?image=http%3A%2F%2Fimage.noelshack.com%2Ffichiers%2F2013%2F49%2F1386167480-iphone-image-12-04-2013.jpg&hash=bea0d642cc4cc078f0e1d2be21643180


Voici mon Index.html:
Vous devez vous inscrire pour voir les liens !

Et mon site (vide pour le moment):
Vous devez vous inscrire pour voir les liens !


Comment régler ce problème de compatibilité entre les différents navigateurs ? :mmh:

Merci :love:
 
Dernière édition:
L'auteur de la discussion a jugé qu'une réponse pertinente à repondu à l'intérrogation de son topic. Cliquez ici pour la voir.

Peaky Blinders

King Plex
Ancien staff
Inscription
27 Décembre 2012
Messages
12 490
J'aimes
5 009
Points
14 493
#2
Il faut mettre le CSS dans le head et non dans le body

HTML:
<!DOCTYPE html>
<html lang="en">
        <head>
                <meta charset="utf-8">
                <title>Site de Darky75</title>
<style "text/css">
                        body
                        {
                                background-image: url("images/fonddesign.jpg");
                                background-position: center center;
                                background-repeat: no-repeat;
                                background-attachment: fixed;
                        }
                </style>
</head>
        <body>
                <p>Mon Premier Site Web !</p>
        </body>
</html>
 
Cette réponse a aidé l'auteur de cette discussion !

Darky75

Membre Premium
Premium
Inscription
27 Septembre 2013
Messages
788
J'aimes
98
Points
3 845
#3
Il faut mettre le CSS dans le head et non dans le body

HTML:
<!DOCTYPE html>
<html lang="en">
        <head>
                <meta charset="utf-8">
                <title>Site de Darky75</title>
<style "text/css">
                        body
                        {
                                background-image: url("images/fonddesign.jpg");
                                background-position: center center;
                                background-repeat: no-repeat;
                                background-attachment: fixed;
                        }
                </style>
</head>
        <body>
                <p>Mon Premier Site Web !</p>
        </body>
</html>
Oui j'avais lu sa sur un tuto, je l'ai mis dans body et sa donnais le même résultat donc j'ai laissé comme sa ^^
Merci de la réponse mais problème persistant :ok:
 


Discussions similaires

Haut